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Arrange Windows and Icons

Use Step-Up Program Manager to arrange your groups so that your icons are easy to see. The Tile 
command resizes and arranges the open group windows side by side in the Step-Up Program Manager 
window. The Cascade command resizes and layers open group windows so that each title bar is visible. A
check mark next to the option in the menu indicates that it is in effect.

To arrange group windows
From the Window menu: choose Cascade, Tile, or Tile Horizontally.

To arrange program-item icons
From the Window menu: choose Arrange Icons. 

You can also make sure that the items in a group window are always arranged whenever 
you change a group window's size, add or move items.      To to this, select Auto Arrange 
from the Options Menu

Special Feature:

When Auto Arrange is enabled Step-Up Program Manager will also auto arrange the main program 
group items.    This is different from the normal behavior of Windows Program Manager.



Choose a Different Icon
You can select any icon from any other icon source available to you.

To choose a different icon

 Select the program item with the icon you want to replace. 
 From the File menu:    choose Properties to bring up the Program Item Properties dialog. 
 In the Program Item Properties dialog box: choose Change Icon. 
 Select the icon you want to use, or Browse for any Icon Source, then choose the OK button. 
 In the Program Item Properties dialog box: choose the OK button. 

Special Feature:

Step-Up Program Manager also allows you to change group icons!    highlight any group icon and 
Select Properties from the File Menu.

Quick Tip:

Click the right mouse button on any group item for the quick menu.    Select Change Icon and 
proceed as usual.



Organize Applications and Documents
Use Step-Up Program Manager to organize your group items into groups that make sense to you. For 
help with organizing applications, choose one of the following topics: 

Arrange Windows and icons 

Change Properties 

Copy a Program Item 

Create and Delete Groups 

Create and Delete Program Items 

Move a Program Item 

Move a Group 



File Menu Commands
Use the scroll bar to see more commands. 

New
Adds an item to a group or creates a new group. 

Open
Starts the selected application and opens an associated document (if there is one), or opens the selected 
group. 

Move
Moves a group or program item to another group.

Copy
Copies a program item to another group. 

Delete
Deletes a group or program item from a group. 

Properties
Changes the properties (such as the description, group file name, or icon)of a group or program item. 

Run
Starts an application and opens an associated document (if there is one), or opens the selected group. 
The Run command also keeps a history of previously run programs. See Run History for details.

Exit Windows
Quits Step-Up Program Manager and Windows. 

New Features:

Find
Find Again



Find Group Item
Find
The Find command helps you quickly locate a program item when you can't remember what group it is in.
Once a group item has been located, the group containing it is automatically opened and the found item is
highlighted. The Find command finds group items by descriptions, command lines, working directories, or 
icon paths. Indicate text restrictions such as containing/not containing, beginning with, and ending with 
text.



Options Menu Commands
A check mark beside the command means it is in effect.    Use the scroll bar to see more commands. 

Auto Arrange
Rearranges the program-item icons in a group window whenever you change the window's size, add new 
items, or move items. 

Minimize on Use
Reduces the Step-Up Program Manager window to an icon whenever you start an application (unless the 
application automatically starts as an icon). 

Save Settings on Exit
Saves the arrangement of Step-Up Program Manager windows and icons when you quit Windows. 

New Features:

Font
Allows you to choose the font, font style, size, and view a sample of the results.

Spacing
Allows you to configure the vertical and horizontal icon spacing, the line mode spacing, and the icon title 
wrap.

Configure
Allows you to configure Step-Up Program Manager features.

Alarms
Set a reminder alarm or schedule a program to run while youre away.    See the Alarms and Scheduled 
Events topic for more.

System Resources
Prevent common program crashes before they happen by monitoring your systems vital resources.    If 
critical components of your windows environment should drop below an acceptable level (a level that you 
can set), youll be notified - and can take steps to ease the strain before you lose any work to a program 
crash.    See the System Resources topic for more...

Mode
Allows you to switch between the different program modes.    See Switching Between Modes for more 
details.



Window Menu Commands

Cascade
Arranges open windows so that the title bar of each window is visible. 

Tile
Arranges open windows side by side vertically so that all of them are visible. 

Arrange Icons
Arranges (into rows) all program-item icons for a selected group.    If a group icon is selected, arranges all 
group icons into rows. 

Group List
The names of your first 9 groups are listed at the bottom of the Window menu.    Select any name from 
this list to quickly open the group.      If you have more than Nine groups, youll see the More Windows... 
menu option at the bottom of the Windows menu. 

Hint: The More Windows control is also available on the toolbar.

New Features:

Tile Horizontally
Arranges open windows side by side horizontally so that all of them are visible. 

Close All
Closes all open windows at once.

Hide All/Show All
Hides open windows so you can find your groups easily.    Show All shows all hidden items. 

View Group As    
Changes the apperance of the group. View the group in Icon, Toolbar or list mode.



Sort Group
Sort your groups alphabetically to make it easier to find items in large groups. Select Sort Group from the 
Window Menu or the  button on the toolbar.



Change Properties
You can change the properties of a program item or the description of a group. 

For program items, you can change the description of the item the working directory where files that the 
application creates are stored The shortcut key for switching to the application when it's running the icon 
that Windows uses to represent the application whether or not the application is minimized to an icon 
when you start it. 
For a group, you can only change the description and the icon.

To change the properties of a program item 

1. Select the icon for the item or group.

2. From the File menu, choose Properties. 
Or, press ALT+ENTER. 

3. In the Program Item Properties dialog box change properties as needed.

4. Click the OK button. 

For help with the Program Item Properties dialog box, choose the Help button or press F1 while using the 
dialog box. 



Create and Delete Groups
Create and delete groups in Step-Up Program Manager to organize your applications and documents. 

To create a group

1. From the File menu choose New. 

2. Select the Program Group option, then click the OK button. 

3. In the Description box, type a description for the group. 
This description will appear in the title bar of the group window and below the group icon. 

4. Click the OK button. 

Step-Up Program Manager creates a .GRP file for the group; you can leave the Group File box blank.

To delete a group

1. Reduce (to an icon) the window of the group you intend to delete. 

2. Select the icon. 

3. Step-Up Program Manager File menu:    choose Delete. 
Or, press DEL. 

4. Delete dialog box: click the Yes button. 
Or, press ENTER. 



Create and Delete Program Items
A program-item icon represents an application, accessory, or document in a Windows group. Select    the 
icon for a program item to start the application or accessory, or open the document.    Create a program 
item by using the mouse to drag a program or document file from File Manager to a Step-Up Program 
Manager group. 

To create a program item

1. Open the group window where you will add an item. 

2. From the File menu, choose New. 

3. Select the Program Item option, then click the OK button. 

4. Fill in the Program Item Properties dialog box as necessary, then click the OK button. 

For help with the Program Item Properties dialog box, choose the Help button or press F1 while using
the dialog box. 

To delete a program item from a group

1. Select the icon for the item you want to delete. 

2. From the File menu, choose Delete. 
Or, press DEL. 

3. In the Delete dialog box, click the Yes button. 
Or, press ENTER. 

When you delete an item from a group, you remove it from the group window, but not from your hard 
disk. 



Move a Program Item
You can move a group or program item from one group to another. When you move a group or 

program item, it is removed from the source group. 

To move a group or program item to another group

1. Open the group window that contains the program item you want to move. 

2. Make sure the destination group window or its icon is visible.

3. Drag the program-item icon to the destination-group window (or icon). 

4. Release the mouse button when the icon is on top of the destination-group window (or icon). 

You can also move a program item by choosing the Move command from the File Menu.



Copy a Program Item
When you copy a program item, the original remains unchanged in the source group.    Group items 

can be copied in the same group, into other group windows or onto the Desktop surface.

To copy a program item to another group using the mouse

1. Make sure that the destination group window or its icon is visible.. 

2. Select the program item you want to copy. 

3. Press and hold down CTRL while dragging the program-item icon from its current location to the 
destination-group window or icon.

4. Release the mouse button and CTRL key when the copied icon is inside the destination-group 
window or on top of the destination-group icon. 

You can also copy a program item by choosing the Copy command from the file menu.



Start an Application with the Run Command
You can use the Run command to start an application that you run only occasionally or have not yet 
added to a group. When you start the application, you can also open a document. 

To start an application with the Run command

1. From the File menu, choose Run. 

2. In the Command Line box, type the path and name, including the extension, of the program file. 
(You can also specify the name of a document to open). For a list of previously run programs click on 
the down arrow at the end of the command line box. This is the Run History list.

Example:

To run Microsoft Word and open a document named STATUS.DOC, in the Command Line box type 
c:\word\word.exe status.doc 
 
1. Select the Run Minimized check box if you want the application to be reduced to an icon when it 

starts. 

2. Choose the OK button. Or, press ENTER.

Tip:

Its easy to start a DOS session from the Run Dialog.    Just type COMMAND (or COMMAND.COM) on the 
command line and a full screen DOS window appears.    Dont forget to type EXIT from the DOS 
command prompt to return to Windows.



Running a DOS Application
If an application belongs to a group, the easiest way to start it is to double-click the program-item icon in 
the group window. If you associate a document with the program item, the document opens when you 
start the application.

To start an application from a group

1. Open the group window that contains the application's program-item icon.
2. Choose the program-item icon. (Double-click it, or choose Open from the File menu.)



Start an Application When You Start Windows
During Windows Setup, a StartUp group is created. When you add an application to the StartUp group, 
the application starts whenever you start Windows. You can add an application to a group by creating a 
program item, or by copying or moving an existing program item. 

Special Feature:
If the StartUp group contains SubGroups all items within the subgroups will be launched.

Hint:
Hold down the SHIFT key when you start Windows to prevent Step-Up Program Manager from launching 
the programs in your Startup Group.



Move a Group
You can move a group from one group to another. When you move a group, it is removed from the source
group. 

To move a group to another group

1. Open the group window that contains the subgroup you want to move. 

2. Open the destination-group window. Or, leave the destination group as an icon if you don't care 
where the icon for the moved group is placed . 

3. Drag the group icon to the destination-group window (or icon). 

4. Release the mouse button when the icon is on top of the destination-group window (or icon). 

You can also move a group item by choosing the Move command from the File Menu .



Copy a Group
Sorry, you can't copy a group.    Look for this feature in the next release of Step-Up Program Manager. 
See Moving a Group.



SwitchBoard
The Step-Up Program Manager SwitchBoard is an alternate way to view your groups with Step-Up 
Program Manager. It also adds a clock and resource/memory monitor.

Below is a summary of SwitchBoard's components.

Easy access to top level groups.    They're always alphabetized    - use the scroll buttons on the right 
to locate any group quickly.

    Quick Buttons. This is a special toolbox group that can be used to quickly run your most commonly 
used programs. Simply drag and drop any group item ( or any file from File Manager ). 

 Analog/Digital Clock. Double-Click on the clock face for the    Clock Configure Dialogbox where you 
can select a different clock face or set an alarm.

 Resource Monitor. The thermometer shows you the percentage of free system resources and 
memory.    Double-Click on the thermometer for the Resource Monitor Dialog to view your 
Environment Variables, System Information, memory Usage and Drive Information.    You can also set
the level of resources you'd like to maintain on your system.

 Run button. Click here to bring up the Run Dialog.

 Find button.    Use this to quickly find any group item.

 Configure Button.    Click here to configure the look of SwitchBoard.



 Help button.

 Parent Group Button.    Use this to navigate to the parent group of the currently displayed group.

 Menu Buttons.



Desktop Buttons

Create a desktop button for your most commonly used applications by simply dragging any item from a 
group and dropping it on the desktop background.    Or use File Manager and drop files on the desktop - a
button will appear with the name of the file and the icon for the associated application.

Here are a few things youll want to know about desktop buttons...

Desktop buttons look similar to, but are very different from minimized running applications. They
simply make it easy to run a program - they are not the running programs themselves and do 
not consume memory and system resources as a running program would. You can 
distinguish a desktop item by the border around the icon and the icon text.

Clicking the right mouse button while over a desktop item will popup a menu listing the following 
items:

Open - Opens the application.    This has the same effect as double-clicking the button.

Move The Move command allows you to move the current desktop item using the keyboard.

Copy - Makes an identical copy of this button on the desktop.

Delete The Delete command will delete the current desktop item.

Properties The Properties command works just like the properties command in the File menu. It 
allows you to change the desktop items Icon, description, command line, working directory 
and shortcut keys.

Tip:

Click the right mouse button anyware on the desktop surface and youll see a quick menu.
Select Arrange Desktop and all your desktop buttons and iconized applications will be 
neatly arranged.



SubGroups
Now you can put a group inside another group!    

With Step-Up Program Manager, youll find that organizing your groups reduces a considerable amount of 
clutter, making it easier to find the group youre looking for.    Subgroups are a convenient way of 
organizing your main groups. With subgroups you can store related groups and launchable items (like 
programs, documents, spreadsheets) into one main group. Any group can contain subgroups and/or 
launchable items. In the example below WordProcessors group is a subgroup of the Application group.



The Run Dialog with Run History

The Run dialog now keeps a history list of the commands youve entered, making re-running them much 
faster and easier -    just select the prior command youd like to replay.

Press the Clear History button the remove all entries from the list.

Hint:
Save some time and click the right mouse button anywhere on the desktop background to see the Quick 
Menu.    Select Run... to get to the Run dialog.



Hide/Show Windows

Select Hide All from the Window Menu to hide all your open group windows. This is especially useful 
when you have several open groups and want to see your top-level group icons. Select Show All to 
unhide all previously hidden group windows. Close All will close all open group windows.



Sort Groups
Use Sort Group from the Window Menu to alphabetically sort all the items in the currently active group. 

Hint:    The feature is also available from the View Window As dialog.    If you check the Change for all 
groups option, youll sort all your groups at once.



Desktop Mode
Now you can utilize your entire desktop without covering up your running programs.    Step-Up Program 
Managers Desktop Mode is an alternate style in which the menus are placed at the top of the screen, and
your groups can be opened anywhere on your desktop.    All your top level groups are located in the group
called    "Quick Access".    To change to Desktop Mode, From the Options Menu Select Mode, Desktop

Some things you may want to know about Desktop Mode:

The Main Menu always available at top of screen.    If the main menu is minimized, all groups ( both 
those that are iconic and those that are open)      are temporarily hidden.

Your group windows are free floating and are no longer limited to size and movement within the Step-
Up Program Manager Window.

The menus apply only to your group windows.



Clock Configure Dialog
The Clock Configuration dialogbox allows you to change the clock type (analog or digital), analog clock 
face,    digital clock color, and clock alarms.

 Clock Faces - Select a clock face to be displayed on the SwitchBoard main window.

 Clock Type    - Choose between Analog and Digital clock types.

 
Alarms area:

 Add - Takes you to the Alarm Setup dialog to create a new alarm.

Edit -    Use this to edit the currently selected alarm. 

 Delete Pressing this button will delete the currently selected alarm.



The Resource Monitor Dialog
Step-Up Program Manager continously monitors your systems vital resources.    You will be notified 
should they drop below an acceptable level that you can choose.    When notified that your Windows 
resources are low, youll have an opportunity to save your work and examine your system - perhaps you 
have too many applications running at once - and can take steps to ease the strain before a program 
crashes.

 Environment Variables Lists the DOS environment variables.

 System Information Lists information about your computer like CPU type, Windows version, as 
well as display, mouse and keyboard information.

 Memory Usage Lists the amount of memory and system resources available.

 Drive Information Lists each drive in your computer along with disk space available on each 
drive.

Alarm Warning Level.    Choose the percentage of free system resources that youd like to 
maintain as a minimum on your system.    If your resources should drop below this level, youll 
receive a warning message.



Switching Between Modes

Select Mode from the Options Menu to select one of the three program modes available in Step-Up 
Program Manager.

 Program Manager mode: Step-Up Program Manager appears to be almost identical to the 
original Windows Program Manager,    but dozens of new features are available.

 SwitchBoard Gives you a Compact view of your groups.

 Desktop mode is another way to view your groups.    The menus are place at the top of the 
screen for easy access and group windows are free floating on the screen.



Configuring Step-Up Program Manager

Select Configure from the Options Menu to customize the look of Step-Up Program Manager. 

Minimized View:
Normal This is the standard application icon.

Clock A working clock.

System Resources System Resource Thermometer.

Enable:
Toolbar Use this to turn the toolbar on or off.

Status Bar Use this to turn the status bar on or off.

More...
Takes you to the More Options dialog where you can configure the look of dialogs and select a 
custom cursor.

When Step-Up Program Manager is in SwitchBoard Mode, the configure dialog is a little different, 
reflecting some of the additional features available to you.

Group Area Size:
Small - The Group display area will display a single column.

Medium - The Group display area will be two columns wide.

Large - The Group display area to be three columns    wide.

Enable Area:
Quick Keys Select this checkbox to turn the Quick Keys area on or off.

Clock/Sys Resource Select this checkbox to turn System Resource Monitor on or off.

General Settings:
Minimize on use Selecting this checkbox will cause SwitchBoard to minimize after you 
lauch an application.

Save Settings on exit Selecting this checkbox will force SwitchBoard to save all 
changes. 



Quick Access Area
The Quick Access Area is a convenient way to access your most commonly used programs and Groups.   
Simply Drag and Drop your favorite icons (or files from File Manager).



View Window As

From the Window Menu, Select View Window As...

Display any or all group windows in one of three different styles:    Icon which mimics Program 
Manager's style; LIST which gives you a multicolumn list mode with icons displayed to the left; and 
TOOLBOX which displays just the icons in buttons grouped as a toolbox. Each display style has 5 
different sizes ranging from 1/2 size to almost 2 times standard icon size. The Change For All Groups 
check box allows you to apply the new style and icon size to all your groups.



Toolbar
The Toolbar allows quick access to commonly used commands. 

Click on a button below for more information.

 Find Group Item

 Find Again 

 Run

 Arrange Items

 Sort Active Group

 Tile Groups

 Cascade Groups

 Close All

 Hide All

 Unhide All

 Icon Display

 List Display

 Toolbox Display

 Icon Size

 Configure



Program Manager Mode
In it's default state Step-Up Program Manager looks almost identical to the standard Microsoft Windows 
Program Manager. However Step-Up Program Manager extends the standard Program Manager features
without requiring you to learn a completely new environment. All standard Program Manager menus, 
commands, keystrokes and group data files are unchanged, just enhanced with these and other features 
that never made it into Windows Program Manager.



Icon Spacing
Choose Spacing from the Options menu to set the vertical or horizontal distance between icons in 
your group windows.    This is especially useful for preventing icon captions from overlapping, or to 
reduce the amount of empty space in a group.



Quick Menus
Click the right mouse button on any group window or on the desktop surface for a quick menu of 
commonly used commands that apply to the item youve selected.



Reminder Alarms & Scheduled Events

Reminder Alarms
Dont be late for another meeting.    Setting a reminder alarm is simple, just select Alarms from the 
Options Menu.    Type in the message youd like to see, select the time and day for the notice and 
youll always get that seat right next to the boss!    For regular events - like many meetings - select the 
days to repeat.

Scheduled Programs
Select the Set Alarm Program button in the alarm setup dialog and select any program youd like to 
run at a scheduled time and day.    Its great for a daily backup at 5:00pm.    If youre still working, just 
select snooze and the event will be on hold for 5 minutes.    If you dont respond to the message within
one minute, the program youve selected will run automatically.

More things you may want to know about alarms and sceduled events...

Youll notice a count down timer inside the Alarm Notification dialog.    For reminder 
alarms, this is preset to 60 minutes.    The dialog will automatically go away when this 
time expires. 

Alarms that are not repeating are automatically deleted from the alarm list once they have
played.

If you have a sound card installed, such as Ad Libs Sound Blaster, you can select any 
sound file to be played when an alarm goes off.    Each alarm can have a different sound.  
Four sounds have been supplied.



Resources
"Resource" generally refers to anything that falls into one of three categories of Windows components - 
System Resources, Memory and Drive Space.

System resources are the basic elements of Windows itself.    There are brushes that applications use to 
paint with different colors on your screen, pens for drawing text, etc.

Applications can behave strangely - from suddenly running very slowly to unusual error messages, to 
heart stopping lockups - should any critical resource run too low.



Icon Source
Icons that you can use to represent a program item are typically a part of the program file itself.    Most 
programs have only one icon, but many have more, and some have dozens. 

There are several other types of files that contain icons that you can use as well. These files normally 
have an extension of .ico, or .dll.

Hint:    Look for a file in your windows directory called MORICONS.DLL.    There are quite a few icons in it 
that you may like to use.



Quick Menu
The Quick Menu appears when you click the right mouse button on the desktop background.

Run... - Select this to get the Run Dialog.
Create... - Takes you to the Create New Desktop Button dialog.
Arrange - Arrange your desktop buttons and iconized applications.



Icon Display Style
    



List Display Style



Toolbox Display Style



Cascade

This is an example of groups that are cascaded.



Tile Groups

This is an example of groups that are tiled.



More Windows

The More Windows control is an alphabetized list of all your groups.      If you have subgroups, youll notice
a     next to the name.      This indicates that this group has subgroups.    Click on the 

 to see the names of the subgroups indented below the name of the parent group.



Icon Sizer
Use this to increase or decrease the size of the icons in the active group.    To change all your groups at 
once, select View Window As... from the Window Menu.



Technical Support
Technical Support is available Monday, Tuesday and Thursday from 10am to 3pm Pacific Time.

(503) 223-6306.
If you have any other questions, comments or suggestions, you may write us at

Step-Up Software
333 SW Fifth Ave. Ste 405
Portland, Oregon 97204

or you may send us a FAX at (503) 223-6632

 




